Jump to content
   
  • Custom Search


Sign in to follow this  
aceuvspades

P0087 check engine code

Recommended Posts

I started getting a check engine light the other day.  I would turn on my car and within a minute the engine would stall.  Then I would turn the car back on and it would run normally from that point, although it showed the check engine light.  I brought it in to Autozone this morning and they checked the check engine code and it came back as P0087.  This code was not in their database for Lincoln cars, although some other car brands were showing that this is related to "Fuel Rail/System Pressure was too low".  My internet searches show codes related to this as well.  Has anyone else had issues with this code before?  I have a 2013 MKZ with the Ecoboost engine.

The one hit I got on this forum for the P0087 code said they replaced the fuel rail sensor and that fixed the problem.  Autozone showed me a "Fuel injection Pressure Sensor" that they said might be the problem.  Is that the same thing as the fuel rail sensor?  Is that something that is pretty easy to change out for someone that doesn't work on cars too much?

Thank you.

Share this post


Link to post
Share on other sites
   

Location of fuel pressure sensor Ford 2.0EB:

https://youtu.be/vlxsO00dZEg

 

As with any DTC, a diagnostic is necessary before just replacing sensors.  The CEL and DTC is telling you that the  sensor is doing its job, not necessarily that the sensor itself is faulty.

Possible caused for a P0087 DTC:

 

P0087.gif

Share this post


Link to post
Share on other sites

Thank you for the information.  I will look into this further before trying to replace the sensor.

Share this post


Link to post
Share on other sites

Same exact thing happening to me with my 2014 MKZ w/echo boost.  Dealer said no codes show up, no engine light comes on and it’s been exhausting trying to figure it out.  Been back and forth to the dealer with no resolve.  Finally realized it only happens wity warm starts. It’s the strangest thing ever.  My powertrain warranty is almost up and am hoping to get it resolved before then.  I had a family member who’s a mechanic look at it yesterday and it sat for 15 minutes before he put it on the diagnostics and started it. It died within a minute or two and that code came up.  He replaced the fuel sensor, I think (behind the rear seat), drove fine, parked it for about 20 minutes, started it and it died.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×