Jump to content

Custom Search





Welcome to the Lincoln MKZ Forum - home of the Lincoln MKZ Club


Sign In  Log in with Facebook

Create Account
Welcome to the Lincoln MKZ Forum. You must register to create topics or post in our community - but don't worry, this is a simple and free process that requires minimal information for you to signup. Be a part of the Lincoln MKZ Forum by signing up for a free account today and enjoy these benefits:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post photos
  • Receive special offers and discounts
  • Invitations to events. . .and more!
Click here to create an account now
 
Guest Message by DevFuse

Check out the Lincoln Continental Forum Here.


Photo
- - - - -

Headlight out


  • Please log in to reply
23 replies to this topic

#21 guamboy

guamboy

    New Member

  • Lincoln MKZ Member
  • Pip
  • 2 posts
  • Region:Australia and Oceania
  • LocationGuam
  • My MKZ's Year:2008
  • My MKZ: mymkz
  • Current Vehicle:2008 Lincoln MKZ

Posted 19 December 2016 - 04:26 PM

Need some help! Recently I changed out the headlight assemblies for my 2008 MKZ from Halogen to H.I.D. I got the H.I.D.'s from a 2007 MKZ . . . my problem is they (H.I.D.) aren't working properly. In a parked position they will work, but once I move into drive or reverse they turn off and the display reads check left & right headlamp (low beam). I installed the relays & fuses but they still don't work properly . . . any clue?







Lose this advertisement by becoming a member. Click here to create a free account.

#22 guamboy

guamboy

    New Member

  • Lincoln MKZ Member
  • Pip
  • 2 posts
  • Region:Australia and Oceania
  • LocationGuam
  • My MKZ's Year:2008
  • My MKZ: mymkz
  • Current Vehicle:2008 Lincoln MKZ

Posted 19 December 2016 - 04:27 PM

Need some help! Recently I changed out the headlight assemblies for my 2008 MKZ from Halogen to H.I.D. I got the H.I.D.'s from a 2007 MKZ . . . my problem is they (H.I.D.) aren't working properly. In a parked position they will work, but once I move into drive or reverse they turn off and the display reads check left & right headlamp(low beam). I installed the relays & fuses but they still don't work properly . . . any clue?



#23 4N1M4L

4N1M4L

    New MKZ Member

  • Lincoln MKZ Member
  • PipPip
  • 89 posts
  • Region:U.S. Mountain
  • LocationPHX
  • My MKZ's Year:2010
  • My MKZ: mymkz
  • Current Vehicle:2010 MKZ AWD

Posted 20 December 2016 - 11:23 AM

Need some help! Recently I changed out the headlight assemblies for my 2008 MKZ from Halogen to H.I.D. I got the H.I.D.'s from a 2007 MKZ . . . my problem is they (H.I.D.) aren't working properly. In a parked position they will work, but once I move into drive or reverse they turn off and the display reads check left & right headlamp (low beam). I installed the relays & fuses but they still don't work properly . . . any clue?

The SJB is likely detecting what it thinks is a bad headlight. You may be better off putting the old ones back in.

 

If you are feeling like trying something you could probably run them their own fuses, and have the old halogen circuit actuate a relay. A relay coil is closer to a halogen bulb than an HID ballast.



#24 Graydons Hip

Graydons Hip

    New Member

  • Lincoln MKZ Member
  • Pip
  • 1 posts
  • Region:Decline
  • LocationDC Metro
  • My MKZ's Year:2009
  • My MKZ: mymkz
  • Current Vehicle:2009 AWD

Posted 25 October 2017 - 08:22 PM

Hello, I'm a new owner of a Used 2009... and for the 1st time in my life I cant simply switch out a headlight bulb! I edited this with a little better sense of what I'm dealing with here

 

About 2 weeks ago the low beam passenger side went out, followed by the other a few days later. I have never had to deal with HID bulbs before and this has not been fun at all. It has D1S installed although the owners manual seems to indicate it should be D3S. Perhaps a previous owner modified to HID? Not that I could figure that out. I finally got the correct bulbs, a low budget alternative (with a healthy amount of positive endorsements), only to discover nothing happened at all after I replaced one side. The opinions on non-OEM hids is split pretty evenly.

 

The ring that secures the hid light to the projecter is stuck on the drivers side, but I was able to unplug the existing bulb, long story short, new bulbs are not working in either passenger or drivers side.

 

Yes, I am wearing gloves and have not touched the bulbs.

 

I am hoping there is a way to troubleshoot ballast, resistors, or wiring harness without having to buy everything first. I have a multimeter, but there are numerous posts that warn against using one to test hid ballast, you'll likely fry the multimeter and possiblly taze yourself. True or False?

 

What is the expected life of hid ballasts? I can't get a consistent answer on this. What would cause them to fail?

 

I am not worried about pulling off bumpers and grilles, but I hate the idea of doing it for nothing.

 

For a good, confident answer I am willing to Burn incense and chant mantras.


Edited by Graydons Hip, 05 November 2017 - 03:47 PM.







Custom Search


Privacy Policy Terms of Service ·