Jump to content
djl5625

Climate Control & Radio problem

Recommended Posts

Hi all. 2017 MKZ Select. Coming home from church Sunday wife went to turn on A/C and noticed it wasnt working. I looked at it when she got home , and nothing on climate control would work. All the lights on panel worked , ie.. blower speed lights, temperature settings on display screen , rear & front defrosters lights , but no blower or anything. I shut off car and restarted and control works good. everything  works as should. Today coming back from gym , she said radio screen blinked few times and music quit same time as the blinks. 

 We bought this car in February and only put less the 2000 miles on it. Mostly sits covered up. It only has 29000 miles on it.

 Do I call a lincoln dealer to have them look at it ? Of course everything is going to work when you take it in , with my luck anyways, or do I wait and see if anything else happen. I just dont want to run up a big bill at the dealership and have them say they have no idea since its working fine now. 

 Or has anyone else heard of such a glitch happening ?

 Thank you all very much for any advice. Other than not let my wife drive it. LOL

Share this post


Link to post
Share on other sites
1 hour ago, djl5625 said:

Hi all. 2017 MKZ Select. Coming home from church Sunday wife went to turn on A/C and noticed it wasnt working. I looked at it when she got home , and nothing on climate control would work. All the lights on panel worked , ie.. blower speed lights, temperature settings on display screen , rear & front defrosters lights , but no blower or anything. I shut off car and restarted and control works good. everything  works as should. Today coming back from gym , she said radio screen blinked few times and music quit same time as the blinks. 

 We bought this car in February and only put less the 2000 miles on it. Mostly sits covered up. It only has 29000 miles on it.

 Do I call a lincoln dealer to have them look at it ? Of course everything is going to work when you take it in , with my luck anyways, or do I wait and see if anything else happen. I just dont want to run up a big bill at the dealership and have them say they have no idea since its working fine now. 

 Or has anyone else heard of such a glitch happening ?

 Thank you all very much for any advice. Other than not let my wife drive it. LOL

 

Hi djl. Is your 2017 MKZ still within the 4 year part of the 4 year/50,000 mile New Vehicle Warranty? If yes, the work will be covered under warranty.

 

If not: An accurate Internet diagnosis of an electronic/electrical issue is difficult at best, nearly impossible in reality. Could be anything from an FCIM or BCM issue, a bad ground, a short, or even a rodent or other varmint chewing on wires somewhere, especially since it "Mostly sits covered up".

 

In my opinion, the best course of action would be to stop by your Lincoln Dealership...or any Lincoln Ford Dealership...next time it occurs. Do not turn off the ignition when you arrive, so you can have it verified while it is happening. Go in and ask them to send out a tech to verify and note the problem is occurring right then. I realize it is inconvenient, but if out of warranty (or even within warranty), it is the best way to handle it at the moment.

 

If one of our tech members has a better idea on this, they will certainly jump in to help.

 

Keep us updated and good luck.

Share this post


Link to post
Share on other sites

I have the same problem with my 13 Hybrid. The dealer tells me I need a new computer ($1,100) and have it programmed for my car. Grand total almost 2,000. Anyone have the $2 fix??

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×