Jump to content
   
OldSkoolBMX

Climate Issues

Recommended Posts

2016 MKZ

127k miles (yes, I know it's a lot)

So I recently noticed when I turn my AC on cold air will only blow out of the passenger middle vent. All other cents blow warm air.

I was thinking AC recharge and almost bought some AC Pro but was told our Hybrids dont use regular stuff and it would ruin our cars.

Anyways, b4 I take it to the Ford dealer for a diagnostic anyone got any ideas what it could be. 

Share this post


Link to post
Share on other sites
   
7 hours ago, OldSkoolBMX said:

2016 MKZ

127k miles (yes, I know it's a lot)

So I recently noticed when I turn my AC on cold air will only blow out of the passenger middle vent. All other cents blow warm air.

I was thinking AC recharge and almost bought some AC Pro but was told our Hybrids dont use regular stuff and it would ruin our cars.

Anyways, b4 I take it to the Ford dealer for a diagnostic anyone got any ideas what it could be. 

Hi OldSkool. I am not an HVAC expert, but here is my Internet diagnosis: The fact that you get cold air out of the center vents would seem to rule out a low refrigerant issue. If it was a refrigerant issue, you would more likely be getting warm air from all registers.  Sounds more like a blend door actuator problem, or other issue of that type.

Out of curiosity, if you switch the air direction to defroster, floor, etc, what air temperatures do you get? And when you switch back to the dash vents, what happens? Still only cold through the one vent?

Hopefully one of our tech members will jump in with more information.

Keep us updated and good luck.

Edited by bbf2530

Share this post


Link to post
Share on other sites
9 hours ago, bbf2530 said:

Hi OldSkool. I am not an HVAC expert, but here is my Internet diagnosis: The fact that you get cold air out of the center vents would seem to rule out a low refrigerant issue. If it was a refrigerant issue, you would more likely be getting warm air from all registers.  Sounds more like a blend door actuator problem, or other issue of that type.

Out of curiosity, if you switch the air direction to defroster, floor, etc, what air temperatures do you get? And when you switch back to the dash vents, what happens? Still only cold through the one vent?

Hopefully one of our tech members will jump in with more information.

Keep us updated and good luck.w

Well I've tried turning it to floor vent and then defrost a few times but it doesn't get any cooler. From what I can feel it stays warm

Share this post


Link to post
Share on other sites
5 hours ago, OldSkoolBMX said:

Well I've tried turning it to floor vent and then defrost a few times but it doesn't get any cooler. From what I can feel it stays warm

Hi OldSkool.  Then in my opinion, it would seem to be a blend door/blend door actuator, or similar problem.  If it was a refrigerant issue, you would not be getting any cold air. The air coming out of the "passenger middle vent" is cold, correct?

Still hoping one of our tech members will jump in here and hopefully point you in a more specific direction to look.

Share this post


Link to post
Share on other sites

Yes, cold AC air blows out of the middle passenger side vent

Share this post


Link to post
Share on other sites
15 hours ago, OldSkoolBMX said:

Yes, cold AC air blows out of the middle passenger side vent

Hi OldSkool.  Then it would seem to be a problem with the HVAC controls/blend doors, blend door actuator etc.  Not a refrigerant issue. 

Keep us updated and good luck.

Edited by bbf2530

Share this post


Link to post
Share on other sites

Keep hoping one of these tech guys you speak ok would chime in 😁

Share this post


Link to post
Share on other sites
18 hours ago, bbf2530 said:

Hi OldSkool.  Then in my opinion, it would seem to be a blend door/blend door actuator, or similar problem.  If it was a refrigerant issue, you would not be getting any cold air. The air coming out of the "passenger middle vent" is cold, correct?

Still hoping one of our tech members will jump in here and hopefully point you in a more specific direction to look.

 

30 minutes ago, bbf2530 said:

Hi OldSkool.  Then it would seem to be a problem with the HVAC controls/blend doors, blend door actuator etc.  Not a refrigerant issue. 

Keep us updated and good luck.

Any idea where to find the location of this blend door and is there possibly 2 since it has dual climate control?

Thanks

Share this post


Link to post
Share on other sites
5 hours ago, OldSkoolBMX said:

Keep hoping one of these tech guys you speak ok would chime in 😁

 

5 hours ago, OldSkoolBMX said:

 

Any idea where to find the location of this blend door and is there possibly 2 since it has dual climate control?

Thanks

Hi OldSkool.  I keep hoping one of them will jump in too. 🤔 I am sure they will, we will just need to be patient, as they get here when they can.

Unfortunately, I can not help you with the location, as my shade-tree mechanic days ended about two decades ago.

I'll keep an eye on your thread though, and will post back with any information I can find that may help.

Edited by bbf2530

Share this post


Link to post
Share on other sites

Found this.  Not exactly for Lincoln but seems they are all in the same area.  Looks like these actuators going is common on Ford products.  A search will return plenty of hits.

https://www.2carpros.com/articles/replace-blend-door-motor

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×