Jump to content
   
NHgirl

2014 stalling issues

Recommended Posts

I’m a Newbee here and am hoping to get some help/advise.

I purchased my 2014 mkz a little over one month ago.  So in love with the car, drive, etc.  About three weeks ago the car just started randomly stalling while pulling out of a parking spot.  It happened randomly and about three to dour times now. Took it to a mechanic two separate times and he put the code reader on but nothing popped up.  Finally he recommended I see the dealer since there are hidden codes that can’t be seen.  Yesterday I took it to the Lincoln Dealer.  He diagnosed the fuel injector pump and luckily it was covered under my 6/70 ( I’m actually at 67400).  He also said my battery charge was very low and transmission fluid is dirty and should be changed.   I pick up the car today, drives beautiful, ran into a store, come out. Start the car and as soon as I pulled from the spot I could tell it was going to stall.  I tried pumping the gas to avoid being hit by the jerk on top of me and nothing.  The green engine light was blinking, pressed that again and it restarted.  The same issue before it went to the dealer!  $428.00  and I’m stalling again.  I believe it may only be stalling while I use the  start button and don’t recall noticing it when I use the key fob.  I’m literally driving myself crazy looking for any answers. 

Share this post


Link to post
Share on other sites
   

Hey everybody.  There is a girl on the site.  Whoopee!  (forgive me if there are others)

Other than that, I got nothing.  But there are some knowledgeable people on this site.  I'm sure they can help ya.  

Welcome aboard and I hope everything works out.

Share this post


Link to post
Share on other sites
2 hours ago, NHgirl said:

I’m a Newbee here and am hoping to get some help/advise.

I purchased my 2014 mkz a little over one month ago.  So in love with the car, drive, etc.  About three weeks ago the car just started randomly stalling while pulling out of a parking spot.  It happened randomly and about three to dour times now. Took it to a mechanic two separate times and he put the code reader on but nothing popped up.  Finally he recommended I see the dealer since there are hidden codes that can’t be seen.  Yesterday I took it to the Lincoln Dealer.  He diagnosed the fuel injector pump and luckily it was covered under my 6/70 ( I’m actually at 67400).  He also said my battery charge was very low and transmission fluid is dirty and should be changed.   I pick up the car today, drives beautiful, ran into a store, come out. Start the car and as soon as I pulled from the spot I could tell it was going to stall.  I tried pumping the gas to avoid being hit by the jerk on top of me and nothing.  The green engine light was blinking, pressed that again and it restarted.  The same issue before it went to the dealer!  $428.00  and I’m stalling again.  I believe it may only be stalling while I use the  start button and don’t recall noticing it when I use the key fob.  I’m literally driving myself crazy looking for any answers. 

Hi NHgirl. Welcome to the Lincoln MKZ Forum! Unfortunately, Internet diagnosis in cases like this is iffy at best.  And there are multiple possibilities which can cause your car to stall.  So, that being said, here is my advice...

First, you can probably discount the starter button/keyfob thing. Yes, you should still tell the service techs what you've noticed about the starter button versus keyfob starting. However, once your car has started, you've shifted into gear and begun to drive away, it has no idea whether you used the starter button or keyfob remote start.

Second - If you had the car repaired by your Lincoln Dealer and it was not fixed correctly, make another appointment (hope you already did) to bring it back in to be re-diagnosed and repaired correctly.

Third -  If I understand your post correctly, they convinced you to replace your battery and have the transmission flushed and filled? What did they charge you, individually, for the new battery and transmission flush/fill? The total sounds high for only a new battery and transmission flush/fill. If it was the original battery, it was not a bad idea to have it replaced anyway. But next time you have your car in, either check the fluids yourself or have someone you trust who knows about cars check them for you.  Maybe the transmission fluid needed changing, maybe it did not. But a trans fluid flush is not called for that early, unless there was a problem (dirty, discolored, burnt, shifting issues etc). I was not there, so could not see the transmission fluid. Therefore, I am not saying the Dealers Service Department necessarily did anything wrong.  But next time, verify for yourself before spending the money.

Your car is still within the 6 year/70,000 mile warranty and they did not correct the original problem, so my advice would be to get your car back in as soon as possible.

Keep us updated and good luck.

Edited by bbf2530

Share this post


Link to post
Share on other sites

Thank you!  Car has been back at the dealer and there are no codes, they cannot find a problem.  They said they tried to duplicate the stalling issue and it will not stall.  He’s going to continue today but I’m starting to feel like this won’t be resolved.  I can’t understand why the car would drive fine, then stall after restarting it when parked for 10 -20 minutes, start back up again and drive fine.  I love this car but am scared of getting hit by another car due to suddenly stalling.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×