Jump to content
   
Sign in to follow this  
willy j

Radio static

Recommended Posts

I recently had to change a fuel injector on the wife's car,  apparently there's a lot of static now on the radio now since then, could a loose battery ground cause this issue or does it have something to do with the new spark plugs. 

Thanks everyone out there in lincoln land. 

Share this post


Link to post
Share on other sites
   
1 hour ago, willy j said:

I recently had to change a fuel injector on the wife's car,  apparently there's a lot of static now on the radio now since then, could a loose battery ground cause this issue or does it have something to do with the new spark plugs. 

Thanks everyone out there in lincoln land. 

Hi willy j. Not exactly sure what is causing your radio static issues. However, what brand of spark plugs did you install?  Hopefully the Motorcraft OEM replacement? Other brands of spark plugs have been known to cause issues with our cars.

Hopefully one of our techie members will jump in with more help.

Keep us updated and good luck.

Share this post


Link to post
Share on other sites
5 hours ago, bbf2530 said:

Hi willy j. Not exactly sure what is causing your radio static issues. However, what brand of spark plugs did you install?  Hopefully the Motorcraft OEM replacement? Other brands of spark plugs have been known to cause issues with our cars.

Hopefully one of our techie members will jump in with more help.

Keep us updated and good luck.

Oh yeah Motorcraft for sure,  i did notice what looked to be a burn holein this harness, not sure what it is but the single wire inside appeared to be ok

20181018_191538.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×