Jump to content
   
Cj7jeepoffroad

Economy meter maxed out all the time

Recommended Posts

Hello this is my first post,

i have a 2014 MKZ 3.7 V6, I’m having a problem with the fuel economy meter being maxed out all the time (as if the car was under acceleration or going up a hill) the average is showing correctly (about 9.5L/100KM) but the instant gauge that is suppose to fluctuate based on throttle or load is maxed at 30L/100km. I did notice the other day as I was sitting in a parking lot with the car running that the meter was bouncing up and down randomly. Has anyone seen this issue?  

 

Thanks

Share this post


Link to post
Share on other sites
   

Welcome to the forums.  There was a TSB for this for certain 2014s.  The IC needs to be reprogrammed.

Share this post


Link to post
Share on other sites

Did you click on the hot link I provided above?   It's TSB 14-0016.

Share this post


Link to post
Share on other sites

The first time I reported that problem with my 2014 MKZ to my dealer I told them, "I think there is a TSB about that."

They "reset the gauge" with the "OK" button on the steering wheel which, of course, didn't fix it.

My next maintenance visit I reported the problem again and gave the service rep a piece of paper with "TSB 14-0116 Fuel Economy Gauge/Bar Stuck" written on it. She didn't type that in the service order, but she did attach my note to the order. The tech performed the TSB and my gauge has been fine ever since.

My car was still under warranty at the time, so I don't know if or what they would have charged to apply the TSB otherwise.

My notes say TSB 14-0116, which I got from Alldatadiy, not 14-0016 as droids mentioned. I don't know which of us has a typo.

Share this post


Link to post
Share on other sites

I have a 2014 3.7 and I don't have any kind of economy gauge that i can see. Just avg mpg when I click fuel economy. Weird.

Share this post


Link to post
Share on other sites
5 hours ago, Mcondo said:

I have a 2014 3.7 and I don't have any kind of economy gauge that i can see. Just avg mpg when I click fuel economy. Weird.

That's what we're talking about.  Same thing.

Share this post


Link to post
Share on other sites
On 11/4/2018 at 8:29 AM, Mcondo said:

I have a 2014 3.7 and I don't have any kind of economy gauge that i can see. Just avg mpg when I click fuel economy. Weird.

The fuel economy gauge (below the trip odometers in the menu) should have a horizontal line showing the average fuel economy, and a vertical bar graph that constantly moves up and down showing your instant fuel economy.

The TSB solves the problem if that vertical instant economy bar disappears.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×