Jump to content
   
Zalvern

3.0T MKZ Drag Strip Adventures

Recommended Posts

Alright so finally got in my first night of drag racing after a long time. However since getting my car back with its new heads, I wanted to see how it performs with just my bolt-on mods but stock tuned. Mostly just to ensure nothing goes wrong with some heavy foot action now that the motor got it workings done.

 

Here are the results:

 

post-1860-0-26326200-1526092213_thumb.jpg

 

Some things to note:

 

-Stock tune with bolt-on upgrades affecting performance: Steeda CAI, UP Intercooler, UP Rear Motor Mount, GFB+ Diverter valve 9358, MSD Coils, Livernois Throttle Enhancer, Ford Performance 70mm Throttle Body, ACES IV Gasoline Formula. Spare tire removed, half tank of gas. I would estimate my weight was between 43XX-44XX or so with me inside.

 

-I'm still practicing with the transmission and learning what it likes best to get the MKZ going so my 60' and such do need work with more time to play. Launching the 6F aggressively from a dig is not easy, especially when trying to optimize power output without too much torque limiting in low gears.

 

-It was a toasty day as it was around 90 degrees during my first three quick passes being 4 minutes apart. DA couldn't have been favorable, and folks were complaining about the track prep.

 

-Noticed wheel hop issues, which also causes shifting to feel delayed in power band. Will definitely get the transmission mount darkstar is working on.

 

-All runs done with sport mode and first three runs were traction control off, last two were advancetrac off. I didn't play with my tire PSI and left them around 40 range heated.

 

Got a lot of attention despite the botchy launches, once it hooks up and torque is freed, it rockets down the strip. Coined "Sleeper Lincoln" title as people remarked how awesome and surprised they were.

 

Dash cam was running so I'll share some videos of front/rear view at least once I get around to uploading them!

 

Next time I will now tune it up with Livernois 93 Octane tune. Perhaps next Friday as long the weather is good!

Edited by Zalvern

Share this post


Link to post
Share on other sites
   

13.2 makes sense for stock tune. You hot lapped the first three runs and things were fairly consistent from a mph perspective so that shows the positive affect of the aftermarket intercooler. I thought there would be a difference between traction control off and advancetrac off, but I guess there isn’t! This is great info. Thanks for posting.

Summer tires right?

Share this post


Link to post
Share on other sites

13.2 makes sense for stock tune. You hot lapped the first three runs and things were fairly consistent from a mph perspective so that shows the positive affect of the aftermarket intercooler. I thought there would be a difference between traction control off and advancetrac off, but I guess there isn’t! This is great info. Thanks for posting.

Summer tires right?

Correct. Drove 20 mins (on a highway) to the drag strip destination, checked in, and immediately jumped in for 3 hot lap pulls due to small line. 90's in temp and humidity around 60%. This was to apply a more "realistic" aspect of continuous driving. Car did not sit except till I did my last two runs. My times improved due to weather temps dropping for the night, cause it takes a real long time for any cooling to drop given our small engine bay and I had to sit in longer lines.

 

On Pilot Super Sports but expect them to be worn given I'll frequent the strip more this year. Will switch to 4S's later.

 

Advancetrac frees up more performance when making turns, as the computer safety will predict and limit power based on wheel and steering angles. It's more useful if at a race track than drag strip.

Edited by Zalvern

Share this post


Link to post
Share on other sites

I'm Confused? I went 12.389@111.47 best of 3 passes, yes I have the Liv tune, and Only the Intercooler..in the 80degree weather...Seems like your Way down on HP???

Share this post


Link to post
Share on other sites

I'm Confused? I went 12.389@111.47 best of 3 passes, yes I have the Liv tune, and Only the Intercooler..in the 80degree weather...Seems like your Way down on HP???

Overall track DA, humidity, launch technique, track location, and track prep. Power was just coming on too late. I raced a modded Charger SRT 392 and that was ticket #4 and he was shocked when mid way I just started pulling away. It was my worst RT and 60' too.

 

It wasn't just my car. A lot of other vehicles were "slower". A GT500 was stuck the 12's who has hit 11's with ease. A Jeep Trackhawk, GTR, Z series Corvettes, and other suped up cars too, not rookies either yet all were underperforming. A tuned Taurus SHO who had Livernois tune and mods was stuck at 13.1 as best and got worse, hit same trap speed as myself. I wanted to race him but he was too bummed at his results.

Share this post


Link to post
Share on other sites

Interesting results I am always amazed at the midrange and or passing power the 3.0T has it actually scares my wife as a passenger.

 

Overall how is the car running now that all the work is finished? Does it idle ok? Overall drivability?

Share this post


Link to post
Share on other sites

True, I missed the Bad DA part..That means A LOT!! In that case you did Great!!

Share this post


Link to post
Share on other sites

True, I missed the Bad DA part..That means A LOT!! In that case you did Great!!

Share this post


Link to post
Share on other sites

Good results for the conditions.   Trap speed tells me that it is making good power.   When stock, my Continental ran 13.56 @ 103 in conditions much like you experienced.

Share this post


Link to post
Share on other sites

No issues with the engine! Its better than ever. Any issues is just fighting with the very conservative ECU that does make it hard to launch these cars. It'll suddenly feel like all the tuning and mods did nothing to help.

 

If you hold throttle to launch too long, the ECU will kill power on launch. It is a very small window. Engine preloading shuts down before turbo spool up enough, even with Livernois tune (it is not aggressive), and torque on the converter just evaporates. This results in a doggy start and time wasted (can be a good 1 second too before the car wakes back up to match throttle input). Getting to 3rd gear without any power penalty is challenging.

 

I have some ideas to try my next time to change my launch style.

Share this post


Link to post
Share on other sites

Heat and stock programming just kills these cars on launch. IDK how you get a decent 60ft time.

Edited by drolds1

Share this post


Link to post
Share on other sites

Any idea what you did on run #3 with the 1.88sec 60ft time?

 

I always tried to scribble in a notebook, the slip,  or document in some way or another what I did at the line on each pass. So I could track launch techniques.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×