Jump to content
Sign in to follow this  
jimflutes

Blower stopped working

Recommended Posts

Drove to the store , blower/heater was fine , get back into car ...no blower , it just stopped working.  I called dealer they made appointment a week later ,a week without heat. The seats and steering wheel still get warm so I can live without the blower for a week.  I am thinking maybe a fuse ? 

Share this post


Link to post
Share on other sites

Well today it started working again .

Share this post


Link to post
Share on other sites

Well, of course it's working again.  It's not 10 degrees any more.  Almost like headlights never burn out on the hottest day of summer.  Only happens on the coldest day of winter.

Share this post


Link to post
Share on other sites

That is a very good point , because it was about 18 when this all happened. It is working very good now although I have to put it up at 80 to get real good heat.

One good thing is that I went into the system and changed the temp setting for the remote start from auto to last temp setting (80),so the car is now warm when I get in.

I am waiting a couple of days to make sure it is ok ,then I will cancel the dealer appointment.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×