Jump to content
   

FaSSt2001

MKZ Member
  • Content Count

    2
  • Joined

  • Last visited

Profile Information

  • My MKZ's Year
    2014
  1. Hi. Sorry, I didn't see these notifications until now. Yes, our issue was the transmission as well and we had to get a new one put it. Our dealership ended up finding us a used one out of a wrecked car and it cost us half the price of a new one. No warranty covered our repairs, but we didn't know about the hybrid parts warranty. They also told us the transmission is sealed and they don't work on them, they only replace them. I'm glad they are covering it under warranty for you. I would have never guessed that sound would be coming from a transmission. Good luck!
  2. Hi. New to these boards. We have a 2014 MKZ Hybrid that has started making a whining noise when the gas engine is running. It only makes the sound when the engine engages and it does it in park and all gears. It's a lot less audible in neutral and reverse though. It gets louder with acceleration as well. I've never heard anything like this before. It resembles alternator whine, but I'm finding out that these cars don't have alternators. The sound is coming from right under the electric motor, but it's so tight right there I can't really see what's there. I made some videos of the sound to hopefully help diagnose it. It's driving us nuts and we really don't want to take it to the dealer. Has anyone heard anything like this on their hybrids (or even gas models) before? Thanks in advance for any input. Ed
×