Jump to content
   

jjr

MKZ Member
  • Content count

    24
  • Joined

  • Last visited

About jjr

  • Rank
    New Member

Profile Information

  • Region
    U.S. Great Lakes
  • Location
    ILLINOIS
  • My MKZ's Year
    2010
  1. Just published You Tube Video also will update Webpage pix later today or tomorrow. https://youtu.be/PaCT4KmatXQ
  2. Priced at $11,325.00 firm, I have close to $14k in this car. Gf needed it for work (and we traveled a lot over the Summer months)now she has moved on and I do not need the car, most miles were highway.. Title clear in my name, located in Chicago 60631 close to O'Hare airport. Decorbonazation (SeaFoam kit https://seafoamsales.com/sea-foam-spray/),air filter, rear brakes, rotors, wipers I have done myself and do have all receipts. All other services have been compleated by Ford w/ receipts with the exception of the new spark plug install and coolant flush, for what Ford wanted for that I opted to have my trusted local Independent shop do the work which saves myself some money. When Ford Quick Lane does the oil change , tires are rotated and the car goes through a full inspection which it has always passed including the most recent service at 57K or so. I had the 60k service done early as Winter is on the way. Tires were TOP OF THE LINE of the line Michelin's purchased from and installed by Ford 2/17 as well as all wheel alignment, also I did purchase the road hazard warranty but I'm unsure if it is transferable. Photos do the car no justice, its very good condition plus plus. If you looking for a great runner with all services up to date and documented this is it. If you live in IL this is a private party sale which means you going to save a lot of money on IL sales tax over buying from a dealer. URL Below http://www.angelfire.com/il3/twins/2010_Lincoln_MKZ.html Video: https://youtu.be/PaCT4KmatXQ Located Chicago, 60631
  3. Nope is all good, also just cleaned the intake system with Seafoam, car is running great. Thanks for getting back
  4. Hi, I just had my spark plugs changed and my idle feels like its 100 rpm too high, anyone know what the factory specifications are for the idle? I have been through my owners manuals and could not find. Also can the idle be simply adjusted? Again its feels good but just a hair too high (just questing 150 rpm +/-) on my tach it looks to be around 800 or a hair lower. Car idle's and runs great, its just my personal preference if I could easily drop it a hair if not no big deal.. TIA
  5. Have a annoying clicking noise I coming from under the left side of the case when the wipers are set in the slower position, I did Google this and found some complaints on other Ford models made in this year and others. My wipers work great other wise but that CLICKlNG is a PITA! Anyone else have this issue? Is it a relay going south? TSB? Fixes ,tips or just live with it??? Tia
  6. Would the arrow in the pix be pointing at the tab you speak of?
  7. Hi, So I have the glove box open and can see the cabin filter door, how do I open it? I see like a open square on each end of the cover and had tried pushing in on those as well as sticking a screw driver in there to see if that would release something, but no luck? Looked at this video but the hand is in the way when they show you how to release the cover??
  8. Had no issues with the car other then the CEL on, only drove the car around the block before I re-plugged the cable back in. Must of caught it in time, also I do have the OBDII scanner here and could of used that to reset it. I lost nothing when I disconnected the negative cable and plugged it back in. Thanks though
  9. Quick update, the fix was simple. Disconnect the neg post of battery , wait a minute and reconnect. Fixed
  10. Quick update, the fix was simple. Disconnect the neg post of battery , wait a minute and reconnect. Fixed
  11. Well just did the above, started the car after I inspected the engine air filter and saw the CEL on so I drove turned off the car and plugged the sensor back in. Then took the car for a couple mile ride and the CEL light is still on. Question is will this re-set it self w/ more miles? Or do I have to hook it up to a OBDII scanner and reset it that way??? TIA
  12. Well just did the above, started the car after I inspected the engine air filter and saw the CEL on so I drove turned off the car and plugged the sensor back in. Then took the car for a couple mile ride and the CEL light is still on. Question is will this re-set it self w/ more miles? Or do I have to hook it up to a OBDII scanner and reset it that way??? TIA
  13. Hi, Just was wondering how many miles you have got on your brake pads? I just bought a 2010 MKZ w/ 47K it had gong through a state inspection just prior to sale and at that time it showed that the front brake pads were 8mm and the rear were 5mm. Being that it was a state safety inspection I'm guessing that I have lots of brake life left? I did try to Google the specifications for the brake pads but could not find. TIA
  14. Hi, My inside rear view mirror has been making a low soft buzzing/hmm sound when I go over bumps, its driving me nuts. If I hold on to the mirror when going over bums there is no noise. The mirror itself is securely mounted and is not loose, the only thing I can think of is that the plastic case is causing the noise. Has anyone else had this issue and if so how was it fixed? TIA
×