Jump to content

Custom Search





Welcome to the Lincoln MKZ Forum - home of the Lincoln MKZ Club


Sign In  Log in with Facebook

Create Account
Welcome to the Lincoln MKZ Forum. You must register to create topics or post in our community - but don't worry, this is a simple and free process that requires minimal information for you to signup. Be a part of the Lincoln MKZ Forum by signing up for a free account today and enjoy these benefits:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post photos
  • Receive special offers and discounts
  • Invitations to events. . .and more!
Click here to create an account now
 
Guest Message by DevFuse

Check out the Lincoln Continental Forum Here.


Photo
- - - - -

unexpected loss of power


  • Please log in to reply
7 replies to this topic

#1 nothappy

nothappy

    New Member

  • Lincoln MKZ Member
  • Pip
  • 2 posts
  • Region:U.S. Great Lakes
  • LocationMilwaukee, WI
  • My MKZ's Year:2007
  • My MKZ: mymkz
  • Current Vehicle:2012 MKZ

Posted 10 April 2015 - 05:16 PM

Has anyone had a MKZ shut down on them while driving?  My daughter has had this happen a couple of times now.  While driving, the dashboard lights flash and she loses power, she cant go more than 25mph.  Had it into the dealer today and they said they have never heard of this and did not have an answer for us after $200 in diagnostics.







Lose this advertisement by becoming a member. Click here to create a free account.

#2 2015mkzhybrid

2015mkzhybrid

    New MKZ Member

  • Lincoln MKZ Member
  • PipPip
  • 80 posts
  • Region:Canada Ontario
  • LocationDunrobin
  • My MKZ's Year:2015
  • My MKZ: mymkz
  • Current Vehicle:2015 Lincoln MKZ Hybrid, 2002 Thunderbird, 2008 Chrysler Sebring Limited Retractable

Posted 10 April 2015 - 05:38 PM

Has anyone had a MKZ shut down on them while driving?  My daughter has had this happen a couple of times now.  While driving, the dashboard lights flash and she loses power, she cant go more than 25mph.  Had it into the dealer today and they said they have never heard of this and did not have an answer for us after $200 in diagnostics.


Did the dealer mention anything about the coils/plugs, or the power control module? No error codes at all showed up from the diagnostics? Hope your mystery gets solved soon.

#3 nothappy

nothappy

    New Member

  • Lincoln MKZ Member
  • Pip
  • 2 posts
  • Region:U.S. Great Lakes
  • LocationMilwaukee, WI
  • My MKZ's Year:2007
  • My MKZ: mymkz
  • Current Vehicle:2012 MKZ

Posted 10 April 2015 - 05:42 PM

It failed 2 days ago, and the dealer said not codes were found in the system,  they also drove it today for a long time with no error codes.



#4 KenZ

KenZ

    New MKZ Member

  • Lincoln MKZ Club Member
  • 103 posts
  • Region:U.S. Southern Atlantic
  • LocationGeorgia
  • My MKZ's Year:None
  • My MKZ: mymkz
  • Current Vehicle:2017 Lincoln MKZ 3.0T

Posted 11 April 2015 - 07:28 AM

It failed 2 days ago, and the dealer said not codes were found in the system,  they also drove it today for a long time with no error codes.

 

Have not had a problem like this.  I did have an issue with the nav system on an Acura a few years ago that they could not replicate at the dealer. It was very frustrating and I was getting no satisfaction.   Finally, I realized that I could take a movie of the problem with my iPhone.  Next time it happened, I took a movie of the nav screen and showed it to them.  They requested a copy of the movie, a few days later, they had a fix.      



#5 4N1M4L

4N1M4L

    New MKZ Member

  • Lincoln MKZ Member
  • PipPip
  • 94 posts
  • Region:U.S. Mountain
  • LocationPHX
  • My MKZ's Year:2010
  • My MKZ: mymkz
  • Current Vehicle:2010 MKZ AWD

Posted 11 April 2015 - 12:09 PM

Almost sounds like its derating for overheating. No codes sounds like replace the ecu.

#6 07_MKZ_WV

07_MKZ_WV

    New Member

  • Lincoln MKZ Member
  • Pip
  • 10 posts
  • Region:U.S. Northeast
  • LocationWV
  • My MKZ's Year:2007
  • My MKZ: mymkz
  • Current Vehicle:07 MKZ

Posted 13 April 2015 - 02:04 PM

This exact thing happened to my 07 MKZ this weekend. However, i was drag racing my friend in his Infiniti G37. At 60 MPH and maybe 7000 rpm she shut off completely. I rolled safely to the next stop light, turned the key back, then forward to start again. She fired right up and has never had an issue since. 

 

Seemed off to me, I've not had it to a shop - but was sort of glad to see that it's happened to someone else.



#7 drolds1

drolds1

    New MKZ Member

  • Moderators
  • 1,125 posts
  • Region:Decline
  • LocationLI, NY
  • My MKZ's Year:Decline
  • My MKZ: mymkz
  • Current Vehicle:2017 MKZ 3.0T AWD Sport Package

Posted 14 April 2015 - 12:14 PM

This exact thing happened to my 07 MKZ this weekend. However, i was drag racing my friend in his Infiniti G37. At 60 MPH and maybe 7000 rpm she shut off completely. I rolled safely to the next stop light, turned the key back, then forward to start again. She fired right up and has never had an issue since. 

 

Seemed off to me, I've not had it to a shop - but was sort of glad to see that it's happened to someone else.

You over-revved it, if you could even get it to 7000rpm.  There's a fueI shutoff/rev limiter.  It probably shut off to protect itself. 

 

This scenario is not the same as described by the OP.  That occurred under, presumably, normal driving conditions and was accompanied by flashing IP lights.



#8 firstlincoln63

firstlincoln63

    New Member

  • Lincoln MKZ Member
  • Pip
  • 2 posts
  • Region:U.S. Great Lakes
  • LocationIllinois
  • My MKZ's Year:2015
  • My MKZ: mymkz
  • Current Vehicle:2015 MKZ Hybrid

Posted 17 June 2016 - 05:38 PM

My 3 month old, 2015 had a similar failure. While leaving an ATM, loss all power, could only go about 5 miles per hour, but had a wrench warning light on the dash. I turned it off, open the door, and then started it up again. That process resets all the electronics. Drove it normally to the dealer who reloaded the computer's memory and told me it was a known problem. I just yesterday drove a loaner MKX (the suv model) and the exact same thing happened. Very scary and dangerous.








Custom Search


Privacy Policy Terms of Service ·