Jump to content

Custom Search





Welcome to the Lincoln MKZ Forum - home of the Lincoln MKZ Club


Sign In  Log in with Facebook

Create Account
Welcome to the Lincoln MKZ Forum. You must register to create topics or post in our community - but don't worry, this is a simple and free process that requires minimal information for you to signup. Be a part of the Lincoln MKZ Forum by signing up for a free account today and enjoy these benefits:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post photos
  • Receive special offers and discounts
  • Invitations to events. . .and more!
Click here to create an account now
 
Guest Message by DevFuse

Check out the Lincoln Continental Forum Here.


Photo
- - - - -

2007 Mkz climate control unit electrical issues

Climate Control

  • Please log in to reply
4 replies to this topic

#1 Jonpeter0420

Jonpeter0420

    New Member

  • Lincoln MKZ Member
  • Pip
  • 3 posts
  • Region:Decline
  • LocationMassachusetts
  • My MKZ's Year:2007
  • My MKZ: mymkz
  • Current Vehicle:Lincoln

Posted 12 August 2017 - 11:04 AM

I recently had my dash pad fixed because Defrost vent was lifting. I picked up my car Friday evening after the shop closed for the weekend. I start the car and my climate control unit will not turn on. I have no lights on the display not even outside temp. as well as no AC no heat no Rear or front defrost. Checked the fuse and its good. Any possible ideas of what Im dealing with here. Id like to resolve this if I can, rather than waiting until monday to bring it back to the guy who repaired my dash pad


Edited by Jonpeter0420, 12 August 2017 - 11:09 AM.






Lose this advertisement by becoming a member. Click here to create a free account.

#2 drolds1

drolds1

    New MKZ Member

  • Moderators
  • 904 posts
  • Region:Decline
  • LocationLI, NY
  • My MKZ's Year:Decline
  • My MKZ: mymkz
  • Current Vehicle:2017 MKZ 3.0T AWD Sport Package

Posted 12 August 2017 - 12:14 PM

IDK what's involved in fixing the lifting vent, but maybe the CC panel was taken out for access and they forgot to plug the connector(s) back in.  You can access the back of the panel by following this video.

 

Just a guess, of course.  Thankfully, it's not too hot in New England this weekend. :)


  • R2D2 and Jonpeter0420 like this

#3 Jonpeter0420

Jonpeter0420

    New Member

  • Lincoln MKZ Member
  • Pip
  • 3 posts
  • Region:Decline
  • LocationMassachusetts
  • My MKZ's Year:2007
  • My MKZ: mymkz
  • Current Vehicle:Lincoln

Posted 12 August 2017 - 01:45 PM

Im going to check it out. Thanks for the advice. Im definitely thankful its not too hot in NE this weekend



#4 Jonpeter0420

Jonpeter0420

    New Member

  • Lincoln MKZ Member
  • Pip
  • 3 posts
  • Region:Decline
  • LocationMassachusetts
  • My MKZ's Year:2007
  • My MKZ: mymkz
  • Current Vehicle:Lincoln

Posted 12 August 2017 - 02:29 PM

I pulled the CC unit and two connectors were unplugged. Plugged them back in and ice cold AC again. Thanks for the advice



#5 drolds1

drolds1

    New MKZ Member

  • Moderators
  • 904 posts
  • Region:Decline
  • LocationLI, NY
  • My MKZ's Year:Decline
  • My MKZ: mymkz
  • Current Vehicle:2017 MKZ 3.0T AWD Sport Package

Posted 12 August 2017 - 05:35 PM

Glad to hear it, Jonpeter :2thumbs: Stay cool.








Custom Search



Also tagged with one or more of these keywords: Climate Control

Privacy Policy Terms of Service ·