Jump to content

Custom Search





Welcome to the Lincoln MKZ Forum - home of the Lincoln MKZ Club


Sign In  Log in with Facebook

Create Account
Welcome to the Lincoln MKZ Forum. You must register to create topics or post in our community - but don't worry, this is a simple and free process that requires minimal information for you to signup. Be a part of the Lincoln MKZ Forum by signing up for a free account today and enjoy these benefits:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post photos
  • Receive special offers and discounts
  • Invitations to events. . .and more!
Click here to create an account now
 
Guest Message by DevFuse

Check out the Lincoln Continental Forum Here.


Photo
- - - - -

06 Zephyr issues


  • Please log in to reply
2 replies to this topic

#1 06zephyr

06zephyr

    New Member

  • Lincoln MKZ Member
  • Pip
  • 4 posts
  • Region:U.S. Southern Plains
  • LocationTexas
  • My MKZ's Year:2006
  • My MKZ: mymkz
  • Current Vehicle:06 Zephyr

Posted 19 August 2016 - 10:34 PM

So i just purchased this 06 Zephyr for my 16 year old daughter and i was hoping someone might could help me with a few issues. First issue is that the oil light stays on constantly...oil level is full and ive changed the oil sending switch also. Next issue is that high beam indicator on the dash stays on regardless whether or not the lights are on high or low beam and the last issue is that the turn signal indicator lights on the dash do not come on but both front and rear turn signals work. Any help would be greatly appreciated.





Lose this advertisement by becoming a member. Click here to create a free account.

#2 drolds1

drolds1

    New MKZ Member

  • Moderators
  • 941 posts
  • Region:Decline
  • LocationLI, NY
  • My MKZ's Year:Decline
  • My MKZ: mymkz
  • Current Vehicle:2017 MKZ 3.0T AWD Sport Package

Posted 20 August 2016 - 01:51 AM

Based on the symptoms, it sounds like all of the issues are actually one issue, i.e., a problem with the instrument cluster.  A service manual or subscription to an online service, like AllData, would be necessary to help troubleshoot the problem.  If you don't want to attempt this yourself, check around your area for a shop that repairs ICs or an automotive electrical repair shop if you don't want to take it to a Lincoln dealer.



#3 06zephyr

06zephyr

    New Member

  • Lincoln MKZ Member
  • Pip
  • 4 posts
  • Region:U.S. Southern Plains
  • LocationTexas
  • My MKZ's Year:2006
  • My MKZ: mymkz
  • Current Vehicle:06 Zephyr

Posted 20 August 2016 - 10:07 AM

Thank you for the response. I was leaning towards that myself but was just wondering if anyone else had ever had those issues as well. Again I appreciate your help.






Custom Search


Privacy Policy Terms of Service ·